KuCoin API issue

Describe the problem:

I get the below error when i try to sync KuCoin via API. I have tried multiple times but it wont work for me. Whats the issue here? All other exhanges have worked fine.

Wallet: KuCoin (KuCoin)
Transactions: 0
Imported with: API

  1. Something went wrong while syncing, try again in a few minutes or contact support.
  2. No transactions found

Which exchange/wallet is this regarding?
KuCoin API

How did you import data into this wallet?
Normal API following the guide (worked fine for other exchanges)

What have you tried to fix this so far?
Have tried multiple times, deleted and created new. So i am not doing anything incorrect.

5 Likes

Having the same issue right now too (worked yesterday). Hopefully they are making improvements to the API to include all data (my initial set of transactions didn’t include deposits or withdrawals). One can hope it will be more stable some day : )

1 Like

Koinly Kucoin just stopped updating AGAIN! Imported the API in again. Still nothing. Koinly is the WORST! I’m gonna give Accointing a try.

1 Like

Same issue for me…
image

3 Likes

Can sync with KuCoin. So Definetly a Koinly Issue

3 Likes

Kucoin exchange sync broke last night after a manaul Koinly sync (AUS east coast time) for me. Re-sync this morning = no good. Deleted exchange in Koinly / re-entered Kucoin exhange API info then sync = no good. Deleted API on Kucoin and started with freshly generated API links = no transactions history at all.

1 Like

Something went wrong while syncing, try again in a few minutes or contact support.

Issue since Jan 12. Tried new API and still does not work.
Worked fine in 2021.

2 Likes

Lots of people with the same issue. Anyone from Koinly that can assist? My KuCoin API works on other sites so clearly a Koinly issue.

3 Likes

Synced for me today but did not include deposit transactions from more than a month ago. More recent deposits were included in the API sync

I get very similar issue with these errors:
Wallet: KuCoin (KuCoin)

Transactions: 0
Imported with: API

  1. 400004: Invalid KC-API-PASSPHRASE
  2. No transactions found

I created several APIs but none works. I hope Koinly fixes this soon because this is my largest transaction account. Else I’d have to look elsewhere.

Yep another person with the issue :expressionless:

1 Like

KUCOIN with Koinly is not working for me either over API – it imports most transactions but no withdrawals or deposits. This is extremely frustrating. Does Koinly ever comment on these tickets? Is this issue being worked?

1 Like

Not working for me either…

I really hope Koinly can get this resolved in the near-term. Tax season is upon us

Does not work. Says access denied, check your API keys. I’ve done that several times.

2 Likes

I reported this issue in December. Koinly support told me they were aware and working on it. Doesn’t look like it’s going to be fixed anytime soon.

1 Like

Exact Same Issue “Access denied, check your API keys”

Hello!

Alex from Koinly here :slight_smile:

This issue has now been fixed, everyone please try creating new API keys and sync them in Koinly, it should work! :slight_smile:

If anyone is still having issues after that please send an email to [email protected] so we can take a closer look.

Sorry about the wait!

Best regards,
Alex

Hello!
I am a web developer and now I am developing new project for kucoin.
I have a few issues in that.
I already create some API key in sandbox.kucoin, but when I request, I receive following message.

{
“code”: “400004”,
“msg”: “Invalid KC-API-PASSPHRASE”
}

I tried them all but none of them are working.
I want your help.
what is exact solution?

I just opened new account here and i will tell then API method not working… Can’t communicate with Kucoin and i have way too much files to use manual method with CSV