Kucoin API Broken - 0 Balance / Missing Transactions - Financial Account

Describe the problem:

KUCOIN UPGRADE 12-22-2022

So Kucoin made changes to what was previously known as Pool-X on 12-22-2021 and now its called the Financial Account. I get rewards or Interest by holding coins there and when I synced my Kucoin account at Koinly what happens is that all the reward transactions show up till 12-22-2021. So basically the day Kucoins upgrade happened Koinly stops syncing the data from the Kucoin Financial Account.

Also on Koinly its shows my balance for coins I have in the Financial account as 0 and im shown an exclamation mark with a hover message that says…

“Some of your calculated balances do not match the balances reported by the API. The differences are listed below”

When I look at the “activity” or transaction history of my Financial account on Kucoin I see that on 12-22-2021, the day of the upgrade there is a transaction labeled “Transfer-in” for the exact amount that Koinly says is the difference when it complains about the calculated balances.

I think Kucoin moved all the coins in an internal transfer from Pool-X to the Financial Account hence the “Transfer-In” Label.

Which exchange/wallet is this regarding?

KUCOIN

How did you import data into this wallet?

API SYNC

What have you tried to fix this so far?

I requested the full csv file for the entire history of my transaction from Kucoin and tried to sync with that and its worse. The rewards transaction don’t show at all. And the balance is still incorrect except this time it shows the balance from before I started earning rewards instead of showing 0.

From my view point its fairly obvious that Kucoin broke the Koinly Integration when they made changes on 12-22-2021 and since that day the balance for what was known as Pool-X but renamed to the Financial Account now shows 0 and rewards stop syncing after 12-21-2021. (the day before the upgrade at Kucoin)

2 Likes

Same issue here. Nothing in Financial account shows up and no transactions are brought through the API.

I gotta get my taxes done so Im looking for solutions. At this point I have manually added the missing transactions for the last 10 days of 2021 that was missing so that income can be included in the tax report.

The balance difference that Koinly complains about is from Kucoin moving the entire sum of the coins that were in pool x to the financial account and I thought I could manually create a withdrawal for the exact same amount Kucoin moved on Dec 22 and then mark it as “sent to pool”.

I figured that would get that wallet balance right and make it so Koinly doesn’t give the exclamation mark but that didnt work. Im not sure why it doesnt work but it doesnt. :frowning:

Im out of Ideas at this point… If anyone else has some input on this issue feel free to chime in.

1 Like

Same issue. I have a negative balance on a lot of my coins that I’ve held for a long time. I believe it must have to do when everything was switched over from Pool-X to Financial Account. Coins that weren’t in the Pool-X account show I have a zero balance on a lot of them. I am paying good money for Koinly to get this right, so please get this fixed. Thanks in advance!

1 Like

I have reported this bug at canny where Koinly keeps track of their bugs. If you could please post there so we can bring some attention to this.

1 Like

Same issue unfortunately here too.
Have Harmony One earning interest in Kucoin financial. Koinly shows nothing. When I search for One through Koinly I can see ONE as rewards are paid out. But Koinly over all shows that I have NO ONE at all. I am confused. I am sure my accountant is going to love me this year.

2 Likes

Thanks for confirming that im not loosing my mind. I have Harmony ONE in Kucoin’s Financial Account too. Actually all I have is ONE in the Financial account. If I wasnt clear in let me try to clear up your confusion. Log in to Kucoin and click on Financial Account on the menu up top! Then on the right hand side click on “Accountant Details”?

Once you are in Account Details Change the filter to show only Harmony ONE, change the date to 1 Year and the Types of Activity to show to “Transfer-In

I bet you on DEC 22, 2021 Kucoin Transferred all the ONE you have to the Financial Account from the Pool-X account on that day and you will see that transaction there and it will labeled Transfer-In. Now the Amount that you see in the amount column is exactly the amount that Koinly shows as the balance difference right**?**

Meaning on Koinly you click on the Kucoin wallet and then on the right side it shows all the coins you have on Kucoin in a list and there it shows you have 0 Harmony ONE coins and there is a yellow circle with an exclamation mark in it right!? And when you move your mouse over the exclamation mark it complains the calculated balance is HIGHER then your actual balance and then it shows the EXACT amount that you see in Kucoins Account details section under the Amount column for that transaction Labeled Transfer-In on DEC 22, 2021.

Here is a Kucoin Staff confirming the renamed Pool-X and that these Transfer-Ins transactions are transactions between your own accounts at Kucoin like from Pool-X to the Financial account or from the main to the trading account.

Koinly does not see this transaction at all!! Hence the exclamation mark and the complaint about the balance difference.

Also check to see that Dec 21, 2022 on KOINLY is that last day you received interest on your ONE right? Even tho you are still earning interest till this day…

It cause there is a bug in Koinly and on dec 22, 2021 when Kucoin renamed or upgraded Pool-X to the Financial account it broke Koinlys Integration and the balance became off and from then on no interest gets recorded on Koinly.

If only I could get some eyes on this. @Alexander_Koinly if you happen to see this we could really use your guidance and more importantly if this can be forwarded to the devs so we get a fix… Thanks in advance.

Hello everyone!

Thank you so much for all of these details @Time_Dj

I will pass this on to our devs right away, it’s definitely something that needs to be looked into!

Hopefully we will have some more information or a fix out soon :slight_smile:

Best regards,
Alex

2 Likes

@Time_Dj

This should have been fixed in late January but we are looking into it now.
Could you try to resync your wallet from the beginning and see if that brings in any of the transactions that are currently missing?
See article below

@Petur_Koinly Thanks for the suggest but I just tried to sync from the beginning and get the same results. The last interest or reward earned that Koinly is able to see is on Dec 21, 2021. After that date rewards coming in from the Financial Account are not recorded by Koinly. The balance for that coin is also still 0 as described and pictured on the canny link I posted on this page. Its the one with the yellow circle with exclamation mark that complains about a difference when you hover over it.

Hello it has been 13 days since the last post. Did anyone manage to solve this issue?

Hey Luksu, I think a fix is in progress. Waiting on word now. I posted the issue on their bugs forum and it has been marked “in progress”. Thats probably the best place to keep track of this issue. Feel free to upvote the post there.

Im really hoping the fix is available soon!

This is still an issue. Signed up today. Set up API twice.
Anybody have suggestions?

Hey… Follow the link I just posted for Luksu. We are all waiting on a fix. Got my fingers crossed it will be out soon.

It appears this is an issue on KuCoin’s end. I am able to query fulfilled orders from earlier this year (2022), but am unable to query my history from last year at all. And yes - I am aware that the API limits you to querying a week’s window at a time and I did provide specific start/end dates when I knew I had made trades.

Here is an example that works for me when providing start/end unix timestamps from this year where I made trades

import API from 'kucoin-node-sdk';
import config from './.config.js';
API.init(config);

const prettyFormatJSON = (data) => JSON.stringify(data, null, 2);

const res = await API.rest.Trade.Fills.getFillsList('TRADE', {
  startAt: 1642377600000,
  endAt: 1642636800000
})
console.log(prettyFormatJSON(res));

Not sure if the data would have been available via the V1 API, but that’s been turned off :roll_eyes:

Thanks for the input … ive tried re-syncing from the beginning with no joy. Im for sure not going to delete and start over so that I wont end up in your situation. It seems like there was issues with the Kucoin api before I reported this problem 30 days go. In fact Petur replied in this thread this issue was supposed to have been fixed in January so I thought it would be a trivial correction but It looks like im mistaken. Big thanks to @Alexander_Koinly for getting eyes on this issue.

@Alexander_Koinly or @Petur_Koinly if you guys can give an ETA on a fix that would be great. If not maybe suggest a work around?

This is what im thinking: Im considering inputting the missing transactions one at a time vai the add transaction button and then creating a manual deposit/transfer transaction for DEC 22, 2021 when Kucoin moved all the funds from our Pool-X wallet to the Financial account. Im not sure what that will mean when the api issue gets alleviated and if that will create double transactions or some sort of duplicate issue as there is no txid for this transaction since its internal move between Kucoin wallets. Im hoping that will fix the reported balance issue tho and manually adding the rewards will at least include those taxable transactions in the report. This is assuming I have grasped the issue at full scope and there is not something else im not seeing from my end.

I reported the issue a month ago on the Kucoin subreddit too and got no response from the mods or anyone who can relay to relevant people.

Kucoin has been a royal pain to deal with. The csv file is not fully supported and the api is just broken and looks like it was broken way before I came around. I think there is another issue with the api if you have “pay fees with kucoin token” enabled as well but I digress.

@Time_Dj does the CSV not contain all the necessary information?
I can try to write a converter (or ideally Koinly could provide something to simplify KuCoin CSV imports), but if it’s missing the required information we might all be SOL until this is resolved.
As of now I can’t even download a CSV file or get the data through the API so I’m waiting for KuCoin to respond to my support request.

Hey Wiz,

The Kucoin csv is missing data. I reached out to Kucoin and asked for a csv file that houses all my transactions since I opened my account at Kucoin and they disappeared for weeks. I was able to get the csv file from them by reaching out to a customer support mod on their subreddit and he got my ticket to the front of the pile.

As it turns out not only was the csv missing data but they only sent me last years transactions. Basically put the api shows I had hundreds of transactions for 2021 and the csv shows like 30 transactions.

Same issue here… Appears it’s a Kucoin problem. I was told after many emails with Kucoin support to contact @KuCoin_API_Aaron_Wang VIA Telegram… I suggest everyone do the same to try and light a fire under them because this still isn’t fixed… and they have known for months. See some highlights of chat below. If anybody knows an easy work around to manually enter an internal transfer that won’t throw everything off please let me know

January 4th
ME. Everything I have under Finance - Savings (what used to be In pool-X - Soft Staking) is now not reporting to my tracking apps like coin stats, koinly, CoinTracker…. I tried redoing the API connection and still nothing. I had no issues seeing my total holdings before the Finance change.

AARON. Checking.

January 6
ME. Any update on this getting resolved? Has this
been confirmed as an issue and is being work
on or?

AARON. I confirmed with our technical team that
querying Finance data requires development
and API query may not be available until next
month.

January 7
ME. Ok thanks for the info. Please let me know
when this becomes available and if there is any
action needed from me once in place or if it
will just start reporting… Not sure why they
wouldn’t have rolled this out when they
changed to Earn as this was the way it was
with pool-X…

AARON. Sure, we will make announcements and
update API documentation at that time.

March 28
ME. Still nothing? When will this be fixed? Please
help

March 29
AARON. Sorry, the release time is estimated to be in
early April. Sorry, the release time is estimated to be in early April.

2 Likes

Any update on Aaron?