Binance API has been upgraded - implications?

Troubleshooting Binance Wallet

I get the message: API has been upgraded

It says to delete my wallet and re-import. I don’t want to because I have done a bunch of work which will be lost.

I assume if I do nothing, the new API be used from now on for my binance API wallet?

What may be in error from the API until now? Some detail would be helpful.

My hope is that I can leave it as it is. Binance seems to have worked ok for me.

Thanks