Uniswap V2 to V3 migration

I used the uniswap migration tool when moving liquidity from V2 to V3.

Koinly doesn’t recognise the move, resulting missing transaction history

Ethereum wallet data imported using the API

I have tried to manually add transactions, with no success, everything I’ve tried results in the same missing transaction warning.

I’m sure there is a way but I cannot work it out.

Hi mate. When I’ve put eth and uni into the pool the api recognised it as “liquidity in” what was fine. It looked like both were swapped to x and y amount of uni-v2 token. So I’ve got a z amount of uni-v2. Then I manually made a transaction what was a swap v2 to v3 with an extra cost separately.
The thing is you might tried the same but the v2 what you used its not the same with that v2 what api used before (there are several v2 with the same name) so it might say you don’t have that v2 so missing transaction. Try to change the uni-v2s (in liquidity in transactions) to the first one what you see in the list, ant use that in the future when you put anything in manually. I hope it could help… I’m trying to get answers about liquidity as well but Koinly doesn’t care about it, what’s sad.

Thanks Csaba. Really helpful, described my issue exactly.
I was unable to change the ‘liquidity in’ token, transactions from api do not allow changes as far as I can tell (new user), but I was able to find the correct Uni-v2 token when manually swapping from V2 to V3.
Thanks again.